A fix has been implemented and we are monitoring the results.
Posted Feb 06, 2025 - 06:54 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 06, 2025 - 06:51 PST
Investigating
We are currently experiencing issues with our Telehealth service. Some users may be unable to connect to their sessions, while others may experience delays.
We are actively working to resolve this issue as quickly as possible. More updates to follow shortly.