Monitoring insurance claims submission
Incident Report for SimplePractice
Resolved
We have had no indications of customer impact from the Crowdstrike issue over the weekend, so we’re closing this incident.
Posted Jul 22, 2024 - 10:19 PDT
Update
All SimplePractice systems continue to perform normally. We are continuing to monitor the situation and will provide updates here.
Posted Jul 19, 2024 - 11:01 PDT
Monitoring
We are aware of the worldwide technology issue caused by Crowdstrike. All of SimplePractice’s systems are performing normally, as are our insurance clearinghouse partners. However, some payers and trading partners are experiencing impacts to their own systems. We will continue to monitor for any issues and post another update in 1 hour (10am PT).
Posted Jul 19, 2024 - 08:45 PDT