This issue has been resolved. We will continue to monitor for any lingering issues and appreciate your patience.
Posted Dec 10, 2024 - 10:53 PST
Identified
We have identified the cause of the issue and are actively working on a fix.
Posted Dec 10, 2024 - 09:35 PST
Update
We are continuing to investigate this issue.
Posted Dec 10, 2024 - 09:23 PST
Update
We are continuing to investigate this issue.
Posted Dec 10, 2024 - 08:13 PST
Investigating
The site is currently experiencing a higher than normal amount of load which may be causing pages and features to be slow or unresponsive. Some users may be unable to login, while others may experience delays or failures in the authentication process.
We are actively working to resolve this issue as quickly as possible. More updates to follow shortly.
Posted Dec 10, 2024 - 08:12 PST
This incident affected: Main application and Telehealth Service.